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Creating Animations with FIJI and ImageJ 
 
FIJI has many tools for creating, editing and annotating movies and still images. This guide was 
written for working FIJI.  Most of these tools are also available in ImageJ but you will need to install 
some plugins not bundled with ImageJ.  
 
1. Getting started with FIJI. 

1.1. Website for Fiji downloads and documentation:  
  https://fiji.sc/#download 

1.2. Follow instructions for Mac or Windows 
1.3. Important difference 

1.3.1. Mac OS – Open Applications directory in the Finder 
1.3.1.1. Right click on Fiji.app  
1.3.1.2. select “Show Package Contents” for the Java Fiji package 
1.3.1.3. Directories for plugins and macros will appear  

1.3.2. Windows OS – Open Applications directory  
1.3.2.1. Fiji will appear as a regular directory 

 
1.4. Supplemental updates for Fiji 

1.4.1. Open the Fiji Updater 
1.4.2. Click on ‘Manage update sites’ 
1.4.3. Select the following: Java-8, Bio-Formats, FFMPEG, Clear Volume 
1.4.4. Click ‘Close’, then ‘Apply changes’ 
This ensures Java 8 compatibility, the latest capabilities for opening files and the FFMPEG 
plugin supports many movie formats 

1.5. Supplemental updates for Fiji 
1.5.1. Additional documentation on ImageJ, applicable to FIJI: 

	 	 	 http://rsb.info.nih.gov/ij/docs/index.html 
1.5.1.1. Click on any Menu Command in the ImageJ documentation 

 
Note that if you need ImageJ to open Quicktime movies, you must use the 32-bit version.  ImageJ 
installs both a 32-bit and 64-bit version.  This is a limitation with Quicktime, which does not support 
64-bit Java. 

 
 
The LOCI plugin is included in FIJI, but must be manually installed for ImageJ.  
http://www.loci.wisc.edu/bio-formats/downloads 
Select the ‘Trunk Build’.  
 
Drag the downloaded file into the ImageJ/plugins directory then start ImageJ.  If the LOCI plugin is 
already installed, then select Plugins menu>LOCI-tools>Upgrade.  ImageJ must be reopened after 
upgrading the LOCI plugin.  Most efficient is to update LOCI first, then update ImageJ. 
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1.6. Generic Instructions for opening a 3D or timelapse file with the LOCI Plugin 
1. Plugins>Bio-Formats; 
2. Select ‘Bio-Formats Importer’; 
3. Navigate to your files and select the file to open; 
4. Set import options (see next section); 
5. Click on ‘Open’. 

 
1.6.1. Basic import options. 

1. All options should be unchecked; 
2. Stack Viewing menu: select “Hyperstack”; 
3. Color Mode: “Custom” or “Composite”; 
4. Select ‘Autoscale’ only if you want a histogram stretch applied to each channel.   

a. Deselecting Autoscale usually scales all channels to the digitization bit depth 
(8-, 10-, 12-, 14- or 16-bits). 

b. If Bio-Formats cannot determine the digitization bit-depth, the image will be 
scaled to the file bit depth (usually 8- or 16-bits). 

5. Click on ‘Open’; 
6. Custom Color Mode only: drag the sliders to set the display color for each channel; 
7. Click on ‘OK’. 

1.7.  Opening movie and video formats – sometimes a different approach is needed 
1.7.1. File>Open; 
1.7.2. File>Import>AVI 

1.7.2.1. Sometimes ‘Virtual Stack’ option is needed 
 

1.7.3. File>Import>Movie (FFMPEG) 
1.7.3.1. Sometimes ‘Virtual Stack’ option is needed 

1.7.4. Plugins>Bio-Formats 
 
A chronic issue/headache exists with competing video formats and resulting 
incompatibilities between different operating systems and software.  Sometimes, Fiji cannot 
open AVI files that contain audio tracks.  Such tracks may be inserted by inflexible 
recording software or by preference settings unbeknownst to the user.   

 
Basic FIJI/ImageJ actions with opened images. 

1. The opened image will initially display only the selected channel; 
2. View all channels by Image menu>Colors>Make Composite…; 
3. All channels will be now displayed. 
4. Options: 

a. Image>Adjust>Color Balance –adjust the histograms limits of a specified channel 
b. Image>Adjust>Color Balance>Set – stretch the histogram for each channel or set all 

channels to the same histogram range (e.g. 0 to 4095). 
c. Image>Properties: Inspect spatial scale and time interval 

 
A. Opening files with FIJI/ImageJ. 
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1. File>Open, recognizes many common formats such as TIFF; 
2. File>Import, uses plugins and the Bio-Formats library to support additional formats, 

importing image sequences and raw formats; 
3. Refer to ImageJ documentation for additional information. 
4. Depending on your version and operating  
 
 

B. Working with movies. 
1. How is a movie created?  
A movie is simply a sequence of images related by time or dimension that is displayed at a sufficient 
rate to create an illusion of motion or depth.  Any image with 2 or more image planes can be 
animated.  
 
A z-series stack can be played “up and down” through its focus planes and a series of 2D images 
recorded over time, a timelapse acquisition, can be played from start to end, and in reverse.   A z-
series stack may also be animated by calculating a projection image at a sequence of of angles to 
create an illusion of rotation.  A timelapse containing a z-series at each time point may be converted 
into a 3D rotation series that will appear to rotate at each time point.  Alternatively, each 3D stack in 
a timelapse may be converted to a 2D projection and these projections played as a time sequence.  A 
more synthetic animation may be created by defining surfaces based on intensity transitions that are 
then  displayed in a series. 
 
2. Can movie images be edited?  
Yes, Fiji allows you to edit the dimensions, adjust colors and annotate images before and after 
turning them into animations. Often, an image is cropped to direct the viewer’s attention to a specific 
feature or event, or its overall size reduced in the final file. The number of images is an important 
factor affecting image quality, playing time, smoothness of transitions between frames and frame 
rate. Other movie editing software can perform additional operations such as transition effects, even 
adding sound. 
 
3. What file formats to use? 
File formats are an important concern.  Most movie formats use compression schemes that 
dramatically degrade image quality and resolution of scientific images.  These are called a “codec” 
standing for “compression and decompressionn”. An excellent way to preserve image integrity is to 
keep animations in the TIFF format until all editing has been completed before converting into a 
compressed movie format.   
 
The MPEG-4 format using the H.264 codec is a good choice for saving movies.  A movie can be 
created by FIJI and saved as ‘Uncompressed’, then exported in the H.264 or several other possible 
formats by Quicktime 7 Pro.  Other applications such as VLC and Periplan can also perform the 
same conversions.   
 
Be aware that QuickTimeX, the default player in Macintosh OSX, cannot play AVI files created by 
ImageJ or FIJI unless the JPEG format is selected when movies are saved.  Although FIJI/ImageJ 
creates high quality JPEG files (minimal compression), there is a risk of accidently resaving the 
movie as a lower quality JPEG with other software.  The Uncompressed format for FIJI/ImageJ 
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movies is “WRAW” in a TIFF file.  It can be opened by Quicktime 7 Pro, VLC, and most other 
movie players on the Mac, but not QuicktimeX.  Another option is to save the FIJI movie images as 
either a TIFF stack or as a series of individual TIFFs. 
  
QuickTime Pro is probably the cheapest and most powerful movie editing tool available, outside of 
FIJI.  Be aware that some of the animation tools in FIJI do not work on Composite color images and 
Hyperstacks (and even more in ImageJ).  This is not really a problem since the applications 
commonly used to play movies will only accept 8-bit and 24-bit RGB images, including Quicktime, 
Windows Media Player, PowerPoint, etc.  Convert a composite image by Image>Color>Stack to 
RGB. 
 
Why compress?  To keep the file size small enough that you can readily open and play the movie.  
Animation intended to play on websites or that will be emailed to colleagues generally cannot be 
more than a few Mb in size.   
 

C. Working with timelapse images. 
 If a timelapse movie has a z-series at each timepoint: 

1. Image Stacks>Z-project stacks; 
2. Select type of projection = Maximum Intensity  [All timepoints], [Slice range]; 
3. Result will be a projection image at each timepoint. 

 
D. Align a z-series or timelapse movie that displays drift between frames 
1. Fiji and ImageJ have many tools for alignment between frames; 
2. Plugins>StackReg (http://bigwww.epfl.ch/thevenaz/stackreg/) works well for minor drift in 

files with a strong feature throughout the image sequence; 
3. If there is a large amount of change between time points or if features change, a timelapse of 

z-series images may need to be aligned as separate z-series.  
4. Manual selection of points may also be required, Plugins>TurboReg 

(http://bigwww.epfl.ch/thevenaz/turboreg/); 
5. FIJI has many alignment tools in the Plugins>Registration folder and by use of Trak2EM for 

both manual and automatic alignment. 
 
Creating Movies. 

A. Play an image sequence as a movie. 
1. Select the open file; 
2. Image>Stacks>Tools>Animation>Options… 

a. Select frame rate, frames per second 
b. Select the extent of frames in the stack that are included in the movie 

3. Choose an option for replaying the animation:  
a. ‘Loop Back and Forth’ plays forward then replays in reverse 
b. no selection plays forward then starts over from the first frame 

4. ‘Start Animation’ begins, a click in the window will stop  
a. Press the “\” key to start and stop any animation 

 
B. Save as an AVI. 

1. Select the open file; 
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2. File>Save As>AVI…; 
3. Options are ‘Uncompressed TIFF’, ‘PNG’, ‘JPEG’, frame rate 

a. QuickTime Player ver. 10 cannot open the uncompressed TIFF. 
b. PNG dramatically alters colors, probably should be avoided 

4. JPEG uses minimal compression 
 

C. Save as an image sequence. 
1. Select the open file; 
2. File>Save As>Image Sequence…; 
3. Select file format from list 

a. Select TIFF to avoid compression 
4. Provide the base file name, each TIFF will be numbered sequentially; 
5. Create a directory into which the files will be saved; 
6. Import the image sequence into QuickTime Pro or other application to create the actual 

animation, or play back within FIJI. 
 
 
 
 

D. Export Quicktime.mov with the LOCI Bio-Formats Exporter plugin.  
1. Create the animation;  
2. Convert to 8-bit or RGB;  
3. Plugins>LOCI>Bio-Formats Exporter;  
4. Enter a filename (the extension “.mov” will be appended on the saved file); 
5. Select ‘QuickTime (*.mov)’ from the File Format menu at the bottom of the Bio- Formats 

Exporter window; 
6. Select the destination; 
7. The format will be uncompressed and frame rate will be 5 fps, these can be changed in 

movie software. 
As stated above, the Quicktime Java modules only work in a 32-bit Java application.  ImageJ may be 
run as either a 32-bit or a 64-bit application.  This will not work with FIJI, which uses 64-bit Java. 
 
Frame rate. 
Although the human eye interprets images as continuous motion when they are presented at 30 
frames per second (fps), much slower rates can be understood to be moving.  Animations with large 
changes between frames may be hard to follow at low frame rates.  Animations of 3D rotations pose 
a question of whether to use a slow frame rate to allow each frame to be studied in detail or a faster 
to provides improved perception of depth.  
  
Methods to reduce and crop the original file 
Many commands are also available in both the Image>Stacks>Manipulation menu and the 
Image>Stacks>Tools menu unique to FIJI.   
 

A. Extract a sub-region to new file. 
1. Create a rectangular region of interest (ROI); 
2. Image>Duplicate  
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a. Select number of channels, z-slices or timepoints to duplicate 
b. A checkbox duplicates the stack within the ROI 
c. Default condition duplicates all dimensions 

3. The entire stack is duplicated if no ROI is selected. 
 

B. Crop file to ROI. 
1. Place a rectangular region of interest (ROI) on the image; 
2. Image>Crop; 
3. Image pixels outside of the ROI are removed. 

 
C. Crop multiple files to same ROI size or position – ROI Manager Method (preferred) 

1. Create an ROI with any of the tools; 
2. Open Analyze>Tools>ROI Manager; 
3. Add the ROI to the manager, ‘Add [t]’; 
4. Perform an operation to the ROI; 
5. Select the next file; 
6. Press ‘Deselect’; 
7. Select the ROI; 

a. the ROI may be moved with the arrow keys, or click and drag within the ROI 
8. Apply the desired action to the stack. 

 
 

D. Crop multiple files to same ROI size or position – Restore ROI Method (laborious) 
1. Create a rectangular ROI; 
2. Perform an operation on the stack; 
3. Select the next file to duplicate 
4. Edit>Selections>Restore Selection 

a. Places the original ROI on the selected image 
5. Perform an operation on the stack; 
6. Repeat as needed. 

 
Non-rectangular ROIs can be used.  However, new stacks or images created by your operations will 
be sized to the smallest bounding rectangle that can fit around the ROI. 
 

E. Rescale image size (add or remove pixels and slices) 
1. Select an image or stack, or create a rectangular ROI within the selected image; 
2. Select Image>Scale: 

a. ‘X, Y, Z Scale:’ Enter the proportion by which the image or ROI is to be re-scaled 
b. integer factors that divide evenly into the pixel dimensions give best results 
c. ‘Width, Height, Depth’: Enter the desired size of output file to which you wish to 

re-scale 
d. ‘Interpolation:’ choices of ‘None’, ‘Bilinear’ and ‘Bicubic’ 
e. ‘Average when downsizing:’ prevents hard edges when scaling to smaller 

dimensions 
f. ‘Fill with background color:’ Select the fill color for empty borders when scale 

factor is  < 1 and not creating a new window. 
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g. ‘Create new window:’ Scaled image/selection is copied to a new image without 
empty borders 

Be aware that rescaling alters pixel intensity statistics.  Never use rescaled images for intensity 
measurements.  
 

F. Transform image orientation and position - flip, rotate, translate 
1. Select Image>Transform; 

a. ‘Flip Z’ – reverses the order of slices in a stack (the first slice becomes the last slice) 
b. ‘Rotate’ - 90 degrees right or left 
c. ‘Rotate’ - arbitrarily, with allowing grids, interpolation, background color, etc. 
d. ‘Translate’ - move the image in the x and y directions, with control over stack 

operations and interpolation. 
Pixel intensities are altered unless transformations are restricted to shifting the image in pixel-wise 
increments.  Such operations would be 90° rotations, flip vertical, flip horizontal or lateral pixel-wise 
shifts. Shifting the image by a fraction of a pixel or rotating in other than 90° increments will cause 
each intensity to partially overlap 2 or more pixel locations.  The overlapping intensities will be 
blended to create new intensities. 
 
The Flip Z option allows the illusion of looping back and forth if your presentation software can’t do 
that. Simply duplicate your movie, perform Flip Z on one copy and concatenate the flipped copy to 
the end of the original movie. Playing the resulting movie from start to end repeatedly will give the 
illusion of a back-and-forth movement. 
 

G. Clear a region of the image. 
1. Place an ROI over a region of the image; 
2. Edit>Clear - replace pixels within the ROI with background color; 
3. Edit>Clear Outside - replace pixels outside of the ROI with the background color; 

 
H. Setting Background Color/Foreground. 

1. Edit>Options>Colors…>Set Background/Set Foreground 
2.  The Eyedropper tool in the toolbar can also be used to select a foreground color by 

clicking in the image to select a color. 
 

I. De-Interleave 
Some image formats interleave channels to create an image that appears to flip between the 
channels as though they were a z-series or timelapse.  A stack with 3 timepoints and 3 
channels might appear as: RGBRGBRGB.  This can be converted into 3 stacks of RRR, 
GGG, BBB. 
 
1. Image>Stacks>Manipulation>Deinterleave 

a. enter number of channels in the stack 
2. Merge the channel stacks to obtain the color merged timelapse. 
 

J. Slice Remover – remove a range of slices from the stack 
1. Merged images must be split into channels; 
2. Image>Stacks>Manipulation>Slice Remover 
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a. enter ‘First Slice:’ - this will be the first slice removed 
b. enter ‘Last Slice:’ - slices will be removed to this limit 
c. enter ‘Increment:’ - starting with the first slice, every nth slice will be deleted 

3. Merge the channel stacks. 
Requires 8-bit or 16-bit, single channel stacks or the resulting stack will be interleaved.  The 
open image is modified. 
  

K. Stack Reduce – remove blocks of slices 
1. Image>Stacks>Tools>Reduce 

a. enter ‘Reduction Factor:’ 
2. Images will be deleted in groups equal to the factor 

a. e.g. Reduction Factor = 3 will delete slices 1-3, 5-7, 9-11… 
3. If the factor is not an even divisor for the number of slices, the resulting number of slices 

will be rounded to the next higher integer. 
Works with any file type.  The open image is modified.   
 

L. Reverse… - same as Image>Transform>Flip Z command.  
The order of slices is reversed so that the first slice in the stack becomes the last.  Useful for 
making rocking projections. 

1. Image>Stacks>Tools>Reverse or Image>Stacks>Manipulation>Stack Reverser 
2. The slice order is reversed. 

 
M. Stack Splitter – Creates sub-stacks containing slices/divisor images 

1. Image>Stacks>Manipulation>Stack Splitter; 
a. Enter the ‘Divisor:’ (integer) 
b. The divisor must be an integer that divide evenly into the slice number 

(planesXchannels); 
2. The stack will be split to a number of stacks set by the divisor. 

RGB and single channel images split as expected.  Composite images split into 
interleaved stacks.   

 
N. Make Substack…	-	Operates on the active stack. 

1. Image>Stacks>Tools>Make Substack… 
2. Follow the instructions in the dialog window to extract a range of slices, or individual 

slices and place them into a new stack.  Same as the Substack Maker plugin. 
a. [Option] delete the range of slices from the original stack after creating the substack; 

Does not work on Composite images. 
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Combining stacks or files using Image>Stacks>Tools/ Image>Stacks>Manipulation 

A. Combine movies – Combines 2 stacks into a single stack 
1. Combine…/Stack Combiner  

a. default action is side by side 
b.  [Option] vertical arrangement 
c. 8-bit, RGB and composite images are supported. 
d. Does not create a new stack, Stack1 becomes the result stack. 

The resulting image window is enlarged to accommodate the stack with the largest dimensions.  
When stacks are not the same width, height or number of frames, the unused areas in the window are 
filled with the background color. See Background Color. 
 

B. Concatenate movies - combine 2 stacks end to end  
1. Image>Stacks>Manipulation>Concatenate…  

a. [Option] Keep source stacks or else Stack1 becomes the result stack 
b. stacks must have same width, height and file type 
c. Stack2 is appended to the end of Stack1 
d. ‘All Open Windows’ will concatenate all stacks in the order that they were opened 
 (in the order of appearance in the Window menu) 

Works with 8-bit or 16-bit grayscale, RGB and composite color.  
  

 
C. Insert - pastes a Source image or stack into a Destination stack. 

1. Image>Stacks>Tools>Insert… or Image>Stacks>Manipulation>Stack Inserter 
a. ‘Select Source Image or Stack:’ 
b. ‘Select Destination Stack:’ 
c. Set the ‘X Location:’ and ‘Y Location:’ for position of inserted image, pixel 

coordinates for the upper left corner of the insert 
d. Click on ‘OK’; 

2. The ‘Source’ image will be inserted into the Destination stack; 
a. The first slice of the Source will display on the first slice of the Destination 

3. The Source and Destination stacks may have any size or number of slices, but both must 
be the same type, e.g. Composite, RGB, bit-depth, grayscale. 

This is useful for placing a high magnification inset into a movie. 
 

D. Montage to Stack- Converts a montage of open images to a stack. 
1. Open a montage; 
2. Image>Stacks>Tools>Montage to Stack…; 

a. select the desired of rows and columns to be included from the montage 
b. click on OK 
c. result will be a stack containing the selected images 
d. This produces the opposite of Image>Stacks>Make Montage. 

 
E. Grouped Z Project - create projections from groups of stack slices 

1. Open a stack, such as a 3D timelapse series; 
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2. Image>Stacks>Tools>Group Z Project 
a. Projection Method sets type of projection 
b. ‘Group size’ selects the number of slices that are projected together 
c. the group size MUST divide evenly into the stack size 
d. all of the FIJI projection methods are available. 

For example, applying a Group size of 3 to a stack of 36 images will create a new stack of 12 
frames, where every 3 images in the original stack are projected to create a frame in the result.   
 

 
e. Works with 8-bit, 24-bit and Composite images.  

See also the plugins Grouped Stack Projector and Grouped ZProjector for ImageJ. 
 
Tarting up your movie. 
Annotations, arrows, boxes and labels for time or events may be added. 

A. Labels and timestamps. 
There are several tools for adding sequences of numbers and/or labels to a stack or 
hyperstack, timelapse or z-series.   
1. Label Stacks, Image>Stacks>Label… 

a. Options: 
i. Format:  

1. 0 – integers 
2. 0000 – padded integers, e.g. 0001, 0002…9999 
3. 00:00 – min:sec 
4. 00:00:00 - hr:min:sec 
5. text 

b. Starting value: initial numerical label 
c. Interval –numerical values will increase by this much for each frame  
d. X location/Y location: enter the x,y coordinates of labels’s upper left corner, in pixels 

i. location may also be defined by drawing a rectangular box on the image 
e. Font Size: can you read it from the back of the auditorium? 
f. Text – display depends on selected Format 

i. Numerical/time formats –time or occurrence units, e.g. min, pulses, µm, etc. 
ii. Text format – caption, event, etc. 

g. Range – which slices are labeled 
i. annotations may restricted to a specified range of stack slices 

h. Use Overlay – apply text as a floating label that may be moved or deleted 
i. Turn this off and annotations will overwrite the image intensities 

ii. Only 1 overlay can be created in an image, existing overlays are removed 
iii. The overlay can be ‘Flattened’ to overwrite image (Image>Overlays) 
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i. Use text tool font:  
i. Default is a sans-serif typeface 

ii. Allows selecting fonts specified in the Fonts widget  (‘A’ icon in the toolbar) 
j. Preview allows viewing the result before accepting it 

i. Check the box to view preview label, de-select to discard the label 
ii. Accept the label by click on ‘OK’ while the preview is visible 

Notes: 
Annotations can be spread horizontally by spaces or tabs. 
Don’t forget to set the font color (foreground color) using the Fonts widget or Edit>Colors. 
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Label Stacks and Series Labeler windows. 
 

2. Series Labeler – Image>Stacks>Series Labeler. 
Similar to Label Stacks, with some different features 
Does not work with Hyperstacks. 

a. Stack Type 
i. time series or movie – allows custom labeling 

ii. z-stack – defaults to label each slice by spatial unit (read from image 
properties or user set) and z-slice interval set by user 

iii. spectral – defaults to providing spectral frequency 
b. Units Formatting 
c. Start/Stop/Interval of Stack 

i. Startup – initial value in a series 
ii. Interval – increment the series values by this much 

iii. Every n-th – only apply label to every n-th frame 
iv. First/Last – restrict labels to this range of frames  

d. Location & Font 
i. X and Y are custom locations 

ii. Location Presets – Upper Left, Lower Left, Upper Right, Lower Right and 
Custom 

iii. Font Settings – brings up the Fonts widget 
iv. Font Color – opens the color selection tool 
v. Background – Applies the annotation on a background (set in 

Edit>Options>Colors) 
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3. Time Stamper - Image>Stacks>Time Stamper 
This is specific for adding time labels to all images in the movie. Z-position could be labeled 
by entering the appropriate Suffix and using a decimal format.  
Best used with grayscale or RGB stacks because font colors can be strange with Composite 
color unless applied to all Composite channels.  

a. Starting Time and Interval - for the initial time and increment interval (or axial depth 
or slice number) 

b. X and Y Locations control placement of the label, in pixels 
i. the region can also be defined by drawing a box on any frame 

c. Font Size – self-explanatory, can you read it from the back of the auditorium? 
d. ’00:00’ format – allows clock format, ignores Decimal places 
e. Decimal places – digits to right of the decimal if not 00:00 
f. Suffix – may be left blank 

 Create plain text labels with Time Stamper: 
a. Set Interval = 0 
b. De-select ’00:00’ 
c. Enter desired text in Suffix 
d. Hit ‘OK’ 

 
4. Set Slice Label, Image>Stacks>Tools>Set Label… 

Slice labels are a line of text displayed in the top margin of a stack, immediately 
above the image.  These are up to 60 characters long (displayed in parentheses).  
The macro functions setMetadata() and getMetadata() may be used to set and retrieve 
the current slice label by a macro. 

 
a. This command requires a stack, but only labels the active frame 
b. Image>Stacks>Tools>Set Label… 
c. Enter text, up to 60 characters 
d. Labeling multiple frames in a movie requires a small macro  
 

5. Remove Slice Labels, Image>Stacks>Tools>Remove Slice Labels 
a. Removes the label from the active frame 

 

The Set Slice Label window displaying the active slice number 
(34).  Text for the label is typed into the box entitled “Label:”. 
 

 
The text “Added label!!!” was inserted into parentheses to right of the active frame 
notation. 
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6. Scale Bars, Analyze>Tools>Scale Bar… 

a. Placement of the scale bar: 
i. Select a Location option 

ii. ‘At Selection’ will place the scale bar at any line or other selection drawn on 
the image 

iii. the selection may be any size, type or angle but scale bar will align with the X 
or Y axis most closely parallel to the selection; 

b. Enter the desired length of the line (width, in units), the line thickness (Height, in 
pixels) and the font size 

c. The scale bar will update to these new values; 
d. The color, background and location will also update with entered values; 
e. ‘Hide Text’ controls visibility of the text; 
f. ‘Overlay’ -  the scale bar is an overlay, otherwise it is bitmapped to the image 
g. Label all slices – do not forget to check this! 

 

 
 

7. Calibration Bar 
a. Creates a copy of the current image and displays an intensity scale based on the 

image’s lookup table 
b. Requires an 8-bit image and any lookup table 
c. The calibration bar is placed according to the Location choice, which includes the 

option to place it at a user defined selection  
d. The Zoom factor: alters the size of the calibration bar to suit the image 
e. ‘Overlay’ allows removing the calibration bar without having altered image 

intensities 
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B. Selecting Background and Foreground Colors. 
1. Select Foreground color for text, scale bar, arrows, etc; 

a. double click on the Eyedropper tool 
b. click on any gray interval, color panel or the Foreground/Background block 

2. Select Background color 
a. Edit>Options>Color. 

 
Convert Composite color animations into RGB color or 8-bit grayscale before adding annotations.   
Composite color only applies the foreground color selection to the currently selected channel.  If you 
want a white scale bar, application of the white scale bar must be repeated into all color channels. 
This is not a serious problem, since any animation intended for presentation software will require 8-
bit grayscale or 24-bit color.  
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1 Using the ImageJ 3D Projection Rendering Tools 

1.1 Projection rendering modes 
ImageJ creates projections through a volume using the back-to-front method, also known as ray-
tracing. Imagine a field of parallel rays passing through a stack of images.  Each ray projects an 
intensity value onto a projection plane (your monitor screen).  The projection value is based upon the 
values of the pixels through which the ray has passed.  The volume projections display an apparent 
rotation if we change the angle at which the rays pass through the stack. Projection parameter 
settings may additionally impart intensities of surfaces at different levels in the volume. 
 
Projection images may be created by the following modes: 
 
Projection Method Result 
Nearest Point Projects the nearest non-transparent point, rendering the nearest 

surfaces; but providing little interior information 
Brightest Point Projects the brightest pixel encountered by each ray as it passes 

through the volume, doesn't discriminate pixel position 
Mean Value Projects the arithmetic mean of all pixels encountered by each ray 

as it passes through the volume; useful for structures within a 
brighter volume 

1.1.1 Projecting a Z-Series onto a single plane 

Sections in a properly collected Z-series stack are all in optimal focus. All objects throughout the 
thickness of the volume will be in sharp focus when projected onto a single image plane. Spatial 
relationships may be more evident, however axial perspective may be obscured.   

The Image>Stacks>Z-Project… sub-menu, the ‘Z Projection…’ command allows quickly creating 
Z-axis projections.    

The Z-Projection window allows you to specify the range of slices to project, for instance the first 
three slices and the last 3 slices might be showing edge artifact from deconvolution. There are 4 
types of projections available, the Maximum Intensity is the most commonly used:  

 

3D Brightest, nearest, mean  
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Projection methods for Z-axis projections to create 2D images.  

The Z-Project command makes projections through the Z-axis with equivalent to these settings 
applied to the 3D Projections: 

  
Initial Angle to 0; 
Total Rotation to 0; 
Rotation Angle Increment to 0; 
Lower Transparency Bound to 0; 
Upper Transparency Bound to 254; 
Surface Opacity to 0; 
Surface Depth-Cueing to 100; 
Interior Depth-Cueing to 0; 
Select Brightest Point for Projection Method; (this changes depending upon type) 

 The Axis of Rotation is irrelevant for this purpose.  
 
 

1.1.2 Rotating the volume 
The volume rotation is controlled in the ‘3D Project…’ command, by editing the degree values in 
the Project dialog. Rotations are created by projecting the volume onto the viewing plane (your 
monitor) at each increment from the starting angle.  View the completed rotational projection by 
selecting this new stack and then choosing the Image>Stacks>‘Animate’ or press “\”.  3D 
projections require RGB stacks. 

1.1.2.1 Projection settings 
There are a number of parameters in the ‘3D Project’ command under the Stacks Menu. 
Understanding their proper use is critical to obtaining acceptable results. 

Projection Method Result 

Average Intensity Projects the arithmetic mean of all pixels encountered by each ray 
as it passes through the volume; useful for structures within a 
brighter volume 

Maximum Intensity Projects the brightest pixel encountered by each ray as it passes 
through the volume, doesn't discriminate pixel position 

Minimum Intensity Projects the darkest pixel encountered by each ray as it passes 
through the volume, doesn't discriminate pixel position 

Sum Slices Projects a real image that is the sum of the slices in the stack 

Standard 
Deviation 

Projects a real image containing the standard deviation of the slices. 

Median Creates an image where each pixel is the median intensity from all 
pixels in the stack for a given pixel position.   
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Slice Spacing: Default is the z-step. 
 
Angles are entered as values in the range of 0° to 360°.   
 
Starting Angle: Sets the initial position of the stack by rotation relative to the Axis of Rotation.  For 
example, an angle of 345° will give an apparent starting position of 15° CCW. (See below) 
 
Total Rotation: Defines the total number of degrees that the volume will be rotated. 
 
Rotation Angle Increment: The total rotation divided by the increment determines the total number 
of projections needed to complete the rotation.   
 
Example: Values of 330°, 60°, 5° will rotate the stack to 330° then make projections every 5° to span 
a total rotation of 60°, from 330° to 30°.  The final stack will contain a total of 13 projections (60°/5° 
plus the starting angle view).  If the images were 512x512, the resulting file will be approximately 
3.5 Mb in size (512x512x13 kilobytes).  
 

Axis of Rotation Effect 
X-Axis The top swings away, rotating around the X-Axis 
Y-Axis The result rotates left to right, around the Y-Axis 
Z-Axis The result rotates clockwise, centered around the Z-Axis 

 
 
Make a brightest point projection. Now go to the ‘3D Project’ command and edit the projection 
angle settings to those in the example above.  Perform rotations in each axis clicking on the buttons 
at the bottom of the dialog, and compare the results. 

Voxel weighting to simulate specimen properties – editing the palette 
These are more difficult to understand, yet are crucial to obtaining fullest benefits from projections. 

‘Lowest transparency bound’ and ‘Upper transparency bound’. 
These values establish thresholds, or a density slice interval. Only pixels having values within the 
range established by these two parameters will be rendered. Pixels selected by the density slice 
interval are shown in red, but will be displayed in grayscale after rendering. 
 
You can use density slicing (thresholding) to set these bounds while moving through the volume. 
The transparency bounds are automatically set to any previously established density slice interval 
when the projection is initiated.   The default values of 0 and 254 select all possible pixels in the 
stack.  Values set here will be applied to all channels. 
 

Depth Cueing. 
The three following functions in the Project dialog box are expressed as values of 0-100%. These 
parameters affect the relative brightness of surface pixels and interior pixels to increase the three-
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dimensional quality of projections.  The tradeoff for enhanced projections is that they no longer 
possess accurate densitometric values. 
 
Surface Opacity (0-100) 
When set to some value greater than zero, and either ‘Brightest Point’ or ‘Mean Value’ are selected, 
this parameter permits the weighted combination of Nearest Point with one of the other two 
projection methods. This enables viewing interior structures through translucent outer surfaces.  The 
default value is zero to make the nearest point surface transparent. 
 
Surface Depth-Cueing (0-100).  
Works only with Nearest Point projections and the Nearest Point component of Surface Opacity 
settings greater than zero.  The default value is 100. 
 
Interior Depth Cueing (0-100). 
This works only with ‘Brightest Point’ projections.   
The default setting is 50%, which may produce a “muddy” result for a plain projection.  Setting this 
to 0% in a Brightest Point Projection may assist in viewing surfaces.  
 
Select ‘Nearest Point’ mode and make a projection with the surface depth cueing set to 50%, then 
100%.   
Now select the ‘Brightest Point’ mode and set the interior depth cueing to 50% and render.  Now set 
the Surface Opacity to 25% or greater and render a Brightest Point projection possessing 50% 
Interior Depth Cueing.  Repeat using the surface opacity settings on a Mean Value projection. 
 
 
Interpolation. 
If the slice spacing is large, the interval between the image planes will appear as a dark line 
separating each bright image plane when the volume rotates to 90°.  The simplest method to avoid 
this unsightly artifact is to only rotate the volume +/- 30° or 45° around the X-axis or Y-axis. 
 
Selecting interpolation will fill in the gaps with additional image planes calculated using bilinear 
interpolation from the existing pixels on each side of the gap.  The resulting projection will look 
much more aesthetically pleasing when viewed at 90°, or perpendicular to the axis of focus.  
However, be aware that the intensities so created are entirely fictitious and cannot be used for 
quantifying intensities or objects.  Also, the file size may dramatically increase.   


